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Exchange Integration Manager Overview
OpenAir Exchange Manager (Exchange Integration Manager)is a Windows-based application that enables
IT system administrators to set up and run the integration between OpenAir and Microsoft Exchange. You
can configure the OpenAir <> Exchange integration to:

■ Export automatically either or all the following OpenAir transactions for any OpenAir user to the
Exchange user mailbox as a calendar event, and update or delete the calendar events in the Exchange
user mailbox when the transactions are changed or deleted in OpenAir. These OpenAir transactions
show in the user's email client's calendar. You can select the type of transactions you want to export to
the Exchange user mailbox for each user.

□ Task assignments — Only task assignments with non-zero planned hours are exported.

□ Bookings — The resulting calendar event will show as Free time, by default. You can map booking
types in OpenAir to specific "Show As" designation for the calendar event in Exchange user
mailboxes so that the resulting calendar event shows as Free, Tentative, Busy, or Out of Office,
and you can prevent bookings from being exported, depending on the booking type. See Mapping
OpenAir Booking Type to Exchange Calendar Event "Show As" Designation.

□ Time off requests (or schedule requests).

Note: Some of these OpenAir transactions are constrained only by dates with no start
and end times. These transactions export as an entire day. The subject line and body of the
calendar event shows information similar to that shown in the OpenAir calendar. See Examples
of OpenAir Transactions Exported as Calendar Events.

■ Import automatically calendar events created by a user in their email client into OpenAir as bookings
for that user, and update bookings in OpenAir when changes are made to the calendar events in
the Exchange user mailbox. This functionality enables users to control OpenAir bookings from their
email client's calendar to some extent. It also makes calendar events created in the email client visible
in OpenAir. You can choose whether to import calendar events from the Exchange user mailbox as
bookings for each user.

Note: By default the integration is unidirectional (export from OpenAir to Microsoft Exchange
only). You must enable the bidirectional integration to import Exchange calendar events into
OpenAir as bookings. For more information, see Configuring the Synchronization of OpenAir
Bookings and Exchange Calendar Events.

If the calendar event includes multiple attendees, the OpenAir <> Exchange integration
imports the Exchange calendar event as different bookings in OpenAir for each attendee if the
bidirectional integration is set up for this attendee. If the user rejects the event invitation or
deletes the event in the email client's calendar, the integration deletes the booking or changes
the booking type, depending on your integration configuration.

The start date and time, and end date and time are adjusted to account for the time zone of
the user. You should refresh the OpenAir user – Exchange user mailbox mapping information
when changing users' time zone preferences change in OpenAir. To do so, launch OpenAir
Exchange Setup and click File > Update. See Setting Up the OpenAir Exchange Integration.

This guide describes the functionality available in OpenAir Exchange Manager 5.0 and later versions.

Exchange Integration Manager
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Note: The OpenAir Outlook Connector add-on service can be used by authorized individual
OpenAir users to export their task assignments, bookings, and schedule requests to their Outlook
calendar. OpenAir Exchange Manager and OpenAir Outlook Connector are mutually exclusive. You
must disable access to OpenAir Outlook Connector for all users on your OpenAir account before
you enable access to OpenAir Exchange Manager.

OpenAir Exchange Manager Components
OpenAir Exchange Manager includes three components:

■ OpenAir Exchange Setup (OpenAirExchange.exe) — Use OpenAir Exchange Setup to set up the
OpenAir <> Exchange integration. See Setting Up the OpenAir Exchange Integration.
You can control:
□ Details necessary to connect OpenAir with Active Directory or Azure Active Directory, and Microsoft

Exchange.
□ Optional bidirectional integration settings, importing Exchange calendar events as bookings in

OpenAir.
□ Mapping information matching each OpenAir user record with a user mailbox.
□ Which OpenAir transactions (task assignments, bookings, time-off requests) are exported to an

Exchange user mailbox for each mapped user.
□ Whether Exchange calendar events are imported into OpenAir for each mapped user, if the

bidirectional integration is enabled.
■ OpenAir Exchange Engine (OpenAirExchangeEngine.exe) — Use OpenAir Exchange Engine to run the

integration. See Running the OpenAir Exchange Integration.
■ OpenAir Exchange Tray Monitor (OpenAirExchangeTrayMonitor.exe) — Use the OpenAir Exchange

Tray Monitor to run, or to stop OpenAir Exchange Engine as a Windows service, and to monitor its
status and activity. See Running OpenAir Exchange Engine as a Windows Service

Examples of OpenAir Transactions Exported as
Calendar Events
The OpenAir <> Exchange integration exports task assignments, resource bookings, and schedule
requests created in OpenAir for a mapped user as an event on the user's calendar in Outlook. The
following examples shows transactions created in OpenAir and exported as Exchange calendar events:

■ OpenAir Task Assignment Exported as Calendar Event
■ OpenAir Booking Exported as Calendar Event
■ OpenAir Schedule Request Exported as Calendar Event

OpenAir Task Assignment Exported as Calendar Event
The following example shows a project task assignment that was created in OpenAir, and then exported
to an Exchange user mailbox as a calendar event using OpenAir Exchange Manager. The calendar event
shows as an all-day event. The Subject line includes the text “OA Task Assignment” followed by the total
time, project name, task ID, and task name. The body of the calendar event includes task information as
well as the customer company name and the project name.

Exchange Integration Manager
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OpenAir Booking Exported as Calendar Event
The following example shows a resource booking that was created in OpenAir, and then exported to
an Exchange user mailbox as a calendar event using OpenAir Exchange Manager. The calendar event
shows the start date and end date selected on the OpenAir booking. The Subject line includes the text
“OA Booking” followed by the total time, customer name and project name. The body of the calendar
event includes the customer name, the project name, the project task name, the duration of the booking,
and notes about the booking, if any.

Note: Depending on your OpenAir account configuration, you may create bookings with a
start date and time and an end date and time. This is enabled when the optional feature Enable
work schedule time ranges is enabled in OpenAir (Administration > Global settings > Account
> Optional features). In this case, the calendar event shows the start date and time, and end date
and time entered on the OpenAir booking. Otherwise, the calendar event shows as an all-day
event.

Exchange Integration Manager
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OpenAir Schedule Request Exported as Calendar Event
The following example shows a schedule request that was created in OpenAir, and then exported to an
Exchange user mailbox as a calendar event using OpenAir Exchange Manager. The Subject line includes
the text “OA Schedule request” followed by the total time, project name, and schedule request status. The
body of the calendar event includes schedule request information (duration, description, and notes).

Exchange Integration Manager
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Getting Started with Exchange Integration
Manager
The following steps outline what you need to do to set up and run the OpenAir <> Exchange integration.

Step 1: Download and Install OpenAir Exchange
Manager
See Installing, Updating and Uninstalling OpenAir Exchange Manager.

OpenAir Professional Services provides you with a link for downloading OpenAir Exchange Manager.

Review System Requirements and Technical Considerations before installing OpenAir Exchange Manager.
For more information, .

Step 2: Ensure Appropriate OpenAir Features are
Enabled
Contact OpenAir Customer Support and ensure that:

■ Access to OpenAir Exchange Manager is enabled for your account.

■ Access to OpenAir Outlook Connector is disabled for your account.

Note: The OpenAir Outlook Connector add-on service can be used by authorized individual
OpenAir users to export their task assignments, bookings, and schedule requests to their Outlook
calendar. OpenAir Exchange Manager and OpenAir Outlook Connector are mutually exclusive. You
must disable access to OpenAir Outlook Connector for all users on your OpenAir account before
you enable access to OpenAir Exchange Manager.

Step 3: Set Up the OpenAir Exchange Integration
Use OpenAir Exchange Setup to configure the OpenAir <> Exchange integration.

You can control:

■ Details necessary to connect OpenAir with Active Directory or Azure Active Directory, and Microsoft
Exchange.

■ Optional bidirectional integration settings, importing Exchange calendar events as bookings in
OpenAir.

■ Mapping information matching each OpenAir user record with a user mailbox.

■ Which OpenAir transactions (task assignments, bookings, time-off requests) are exported to the
Exchange user mailbox for each mapped user.

■ Whether Exchange calendar events are imported into OpenAir for each mapped user, if the
bidirectional integration is enabled.

Exchange Integration Manager
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For more information, see Setting Up the OpenAir Exchange Integration.

Step 4: Run the OpenAir Exchange Integration
After you configure the OpenAir <> Exchange integration, you can run OpenAir Exchange Engine to
export task assignments, bookings, and time off requests (schedule requests) from OpenAir to Exchange
user mailboxes as calendar events and import calendar events from Exchange user mailboxes to OpenAir
as bookings if the bidirectional integration is enabled.

If you use OpenAir Exchange Manager 5.0 or later version, you can run OpenAir Exchange Engine as a
Windows service.

For more information, see Running the OpenAir Exchange Integration.

Exchange Integration Manager
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System Requirements and Technical
Considerations
OpenAir Exchange Manager is a Windows-based application that enables IT system administrators to
set up and run the integration between OpenAir and Microsoft Exchange. This help topic includes detail
about the following system requirements and technical considerations:

■ System Requirements to install, configure and run OpenAir Exchange Manager on your computer.
■ Infrastructure that OpenAir Exchange Manager supports.
■ Communication Interfaces used by the OpenAir <> Exchange integration.
■ Role Permissions required to set up and run the OpenAir <> Exchange integration.

Infrastructure
You can use the OpenAir <> Exchange integration with an on-premise Windows domain network
configuration, a cloud-based environment, or an hybrid configuration.

On-premise Online Hybrid

Active Directory (LDAP protocol) Azure Active Directory —

All mailboxes stored in Exchange Server
organizations.

Supported versions: 2007 SP1, 2010, 2010 SP1,
2010 SP2, 2013, 2013 SP1, 2016.

You must run the same version of Microsoft
Exchange Server across all instances to use the
integration with mailboxes stored in multiple
Exchange Server organizations.

All mailboxes stored
in Exchange Online
organizations.

Some mailboxes are stored in
Exchange Online organizations,
some in on-premise Exchange
organizations.

Note: Review the following guidelines:

■ If Active Directory is not available, you need to set up mapping between OpenAir and Exchange
Server users manually.

■ If some or all mailboxes are stored in an on-premise Exchange organization, you should install
OpenAir Exchange Manager on a separate server or workstation on the same network as the
company's Exchange server. This ensures the integration has access to Active Directory to
query users, but does not store the integration configuration on the same server.

■ If OpenAir Exchange Manager is set up on a remote server outside the company network, the
integration typically needs VPN access to the company network to be able to interface with the
Exchange server.

System Requirements
The following requirements must be met to install, configure, and run Integration Manager on a :

Exchange Integration Manager
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■ Operating System
□ Microsoft Windows Server 2012, 2012 R2, 2016 or 2019
□ Microsoft Windows 8, 8.1 and 10

■ Microsoft .NET Framework Version 4.7.2.

Note: The OpenAir Exchange Manager installer automatically downloads it if it is not installed
on your computer.

■ RAM 1GB or more.

Communication Interfaces
OpenAir Exchange Manager use the following communication interfaces:

■ OpenAir XML API to transfer information from and to OpenAir over a secure layer using the HTTPS
protocol (port 443). No incoming ports need to be opened in the firewall.

■ Active Directory Services Interface (ADSI) and Lightweight Directory Access Protocol (LDAP) to
communicate with on-premise Active Directory and retrieve the user information (email address and
home mailbox server) required to map Exchange user mailboxes (and associated Active Directory user
accounts) with OpenAir user records.

■ Exchange Web Services (EWS) to connect to Microsoft Exchange and create calendar events in user
mailboxes.

Important: Note the following compatibility guidelines:

□ OpenAir Exchange Manager 5.0 or later version does not support WebDAV. If you are using
Microsoft Exchange Server 2007, you will be required to use EWS instead.

□ Microsoft no longer supports Basic authentication for EWS to access Exchange Online.
OpenAir Exchange Manager 5.1 introduced support for using OAuth 2.0 to connect to
Exchange Online using EWS. To configure and run the integration between OpenAir and
Microsoft Exchange Online, you must use OpenAir Exchange Manager 5.1 or later version
and register OpenAir Exchange Manager with Azure Active Directory. See Registering
OpenAir Exchange Manager With Microsoft Identity Platform.

Role Permissions
To set up and run OpenAir <> Exchange integration you must have user accounts with the following
permissions:

Software Role permissions Notes

OpenAir Account administrator Required to read and update all task assignments, resource
bookings, and schedule requests.

Active Directory Domain administrator Required to read the user information (email address and
home mailbox server) required to map Exchange user
mailboxes (and associated Active Directory user accounts) with
OpenAir user records.

Exchange Integration Manager



Role Permissions 9

Software Role permissions Notes

Administrator Required to grant access to user mailboxes and modify
Exchange settings if necessary.

Microsoft Exchange

Read and Write access
permissions to all user
mailboxes

Should be used to run OpenAir Exchange Engine, which does
not require Exchange or Enterprise administrator privileges.

Windows /
Windows Server

Administrator Required to run OpenAir Exchange Setup and OpenAir
Exchange Engine applications.

Known Limitations
The integration has the following limitations:

■ Exchange Web Services (EWS) limits the calendar item duration to five years maximum. If any task
assignments, resource bookings or time off requests exceed five years in OpenAir, the integration
automatically sets the duration of calendar events to five years (maximum duration supported by
EWS).

Backup
You should backup the file containing your OpenAir <> Exchange integration configuration settings
(oaexchdb.mdb) periodically. The file is located in the OpenAir Exchange Manager installation folder –
typically, C:\Program Files (x86)\OpenAir\ExchangeManager.

Exchange Integration Manager
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Installing, Updating and Uninstalling
OpenAir Exchange Manager

Important: You must disable access to OpenAir Outlook Connector for all users on your
OpenAir account before you start using OpenAir Exchange Manager. These two add-on services
cannot run simultaneously for the same OpenAir account.

OpenAir Professional Services provide you with a link to download the OpenAir Exchange Manager
installer EXE file as part of the initial setup. You use this link to download and install the latest version of
OpenAir Exchange Manager. For more information, see .

Before you install OpenAir Exchange Manager, review the system requirements and technical
considerations – see System Requirements and Technical Considerations.

You should review OpenAir Release Notes regularly and update OpenAir Exchange Manager to the latest
available version to take advantage of new features, product enhancements and defect fixes.

You can uninstall OpenAir Exchange Manager at any time. For more information, see Uninstalling OpenAir
Exchange Manager.

Installing or Updating OpenAir Exchange Manager
Use the following steps to install or update OpenAir Exchange Manager. You do not need to uninstall the
current version to update OpenAir Exchange Manager to the latest version.

The following steps are given for Windows 10.

To install or update OpenAir Exchange Manager:

1. Download the installer EXE file using the link provided by OpenAir Professional Services.

2. Run the OpenAir Exchange Manager installer file. You must have administrator rights for the
computer on which you are installing OpenAir Exchange Manager and run the installer as and
administrator.

If Microsoft .NET framework 4.7.2 is not installed on your computer, a popup window appears
prompting you to download and install an update supplied by Microsoft.

a. Click Yes.

Note: Microsoft .NET framework 4.7.2 is required to run OpenAir Exchange
Manager 5.0 or later version. If you click No, the installer will close and OpenAir
Exchange Manager will not install.

b. A new window or tab opens in your default browser and the following message displays.
Click Run.
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Important: You should exit all applications that are using the .NET framework
before you install this update. You may have to restart your computer after installing
the Microsoft .NET framework 4.7.2 update.

c. After the installation Microsoft .NET framework 4.7.2 completes, restart your computer if
required and run the OpenAir Exchange Manager installer file again.

The OpenAir Exchange Manager installation wizard appears.

3. Click Next.

4. Read and accept the License Agreement then click Next.

5. Choose the location to install OpenAir Exchange Manager then click Next.

The default location is C:\Program Files(x86)\OpenAir\ExchangeManager.

6. Review your installation settings, then click Install.

The wizard shows the installation progress. After the installation completes, the wizard shows
information about the application (the content of the README.TXT file).

7. Review the content of README.TXT, then click Next.

8.

9. Check the View readme.txt box if you want to open README.TXT automatically in you default text
editor after you exit the installation wizard.

10. Check the Start tray monitor now box if you want to launch OpenAir Exchange Engine Monitor
automatically and make it available in the Taskbar System Tray after you exit the installation wizard.

Exchange Integration Manager



Uninstalling OpenAir Exchange Manager 12

11. Click Finish.

Five shortcuts are available from the Windows Start menu under the OpenAir Exchange Manager
program folder:

■ OpenAir Exchange Manager – Use this shortcut to launch OpenAir Exchange Setup and set up
the integration. See Setting Up the OpenAir Exchange Integration

■ Start Engine, Stop Engine, and Show console logs for Engine – Use these shortcuts to run,
stop the integration and show logs for the integration, respectively. See Running the OpenAir
Exchange Integration.

■ Tray Monitor – Use this shortcut to launch OpenAir Exchange Tray Monitor and make it
available in the Taskbar System Tray.

Uninstalling OpenAir Exchange Manager
You can uninstall OpenAir Exchange Manager at any time if you no longer plan to use OpenAir Exchange
Manager or if you want to install it on a different computer.

The following steps are given for Windows 10.

To uninstall OpenAir Exchange Manager:

1. Click the Windows Start menu icon, then Settings.

The Settings screen appears.

2. Click Apps & Features.

The Apps & Features screen appears and lists the applications installed on your computer.

3. Locate and click OpenAir Exchange Manager.

4. Click Uninstall.

A prompt appears to verify the action.

5. Click Yes.

A message appears verifying the action.

6. Click OK.

7. (Optional) Delete the installation folder. The default installation location is C:\Program Files
(x86)\OpenAir\ExchangeManager but you can choose a different location during the installation –
see Installing or Updating OpenAir Exchange Manager.

Exchange Integration Manager
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Important: Uninstalling OpenAir Exchange Manager does not delete the configuration
settings and OpenAir users <> user mailboxes mapping information.

To remove all settings completely, delete the installation folder.

Exchange Integration Manager
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Setting Up the OpenAir Exchange
Integration
You must configure OpenAir Exchange Manager before you can use the OpenAir Exchange Engine to
run the integration and transfer OpenAir transactions such as task assignments, bookings, and time off
requests (or schedule requests) to Microsoft Exchange as a calendar event in user mailboxes.

Use OpenAir Exchange Setup to configure the OpenAir <> Exchange integration.

For an overview of the main OpenAir Exchange Setup window and menu options, see OpenAir Exchange
Setup Overview

To set up the OpenAir <> Exchange integration:

1. Launch OpenAir Exchange Setup. To do so, do one of the following:

■ Go to the application installation directory (the default installation directory is C:\Program Files
(x86)\OpenAir\ExchangeManager). Click OpenAirExchange.exe.

■ Go to the Windows start menu, scroll down to OpenAir Exchange Manager, expand the
program folder and click OpenAir Exchange Manager.

■ If you installed OpenAir Exchange Manager 5.0 or later version and selected Start tray
monitor now during the installation, right-click the OpenAir Icon in the taskbar system tray and
click Setup.

2. Enter the details to connect OpenAir Exchange Manager with your OpenAir account. See
Connecting OpenAir Exchange Manager with your OpenAir account.

3. Go to Options > Integration Settings.

The Integration Settings window appears.
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4. Select a date from the Export records created or modified after dropdown list. When running
the OpenAir <> Exchange Integration, only the task assignments, bookings, and time off requests
created or modified after this date are exported to user mailboxes as calendar events.

5. Enter the details to connect OpenAir Exchange Manager with Active Directory and Exchange.

You can use the OpenAir <> Exchange integration with an on-premise Windows domain network
configuration, a cloud-based environment, or an hybrid configuration. See Infrastructure.

a. Before you can connect OpenAir Exchange Manager with Azure Active Directory, Exchange
Online, or both, register OpenAir Exchange Manager with the Microsoft identity platform.
See Registering OpenAir Exchange Manager With Microsoft Identity Platform.

b. Enter the details to connect OpenAir Exchange Manager with Active Directory (on-premise)
or Azure Active Directory. When connected, OpenAir Exchange Setup sources user mailbox
information from Active Directory or Azure Active Directory. You can also enter user mailbox
information manually or import it from a CSV file. See Editing Exchange User Mailbox
Information.

■ On-premise Active Directory — For more information, see Connecting OpenAir Exchange
Manager with On-Premise Active Directory Using LDAP.

■ Azure Active Directory — For more information, see Connecting OpenAir Exchange
Manager with Azure Active Directory or Exchange Online.

c. Enter the details to connect OpenAir Exchange Manager with Exchange. You can use
OpenAir Exchange Manager to exchange information between OpenAir and user
mailboxes that are stored in on-premise Exchange Server organizations, in Exchange
Online Organizations, or in a combination of both Exchange Server and Exchange Online
organizations.
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■ On-premise Exchange (mailboxes stored in Exchange Server organizations) — For more
information, see Connecting OpenAir Exchange Manager with On-Premise Exchange
Server.

■ Exchange Online (mailboxes stored in Exchange Online organizations) — For more
information, see Connecting OpenAir Exchange Manager with Azure Active Directory or
Exchange Online.

6. (Optional) Configure OpenAir Exchange Manager to send integration log automatically by email.
See Sending OpenAir Exchange Integration Logs to a Designated Email Address.

7. (Optional) Enable and configure the bidirectional integration. You can use the bidirectional
integration or Exchange <> OpenAir synchronization to import calendar events created by a
user in an email client into OpenAir as bookings for that user, and update these bookings when
changes are made to the calendar events in the email client. See Configuring the Synchronization
of OpenAir Bookings and Exchange Calendar Events.

8. (Optional) Map booking types in OpenAir to specific "Show As" designation for the calendar event
in Exchange user mailboxes so that the resulting calendar event shows as Free, Tentative, Busy,
or Out of Office, depending on the booking type. You can also exclude bookings from the export,
depending on the booking type. See Mapping OpenAir Booking Type to Exchange Calendar Event
"Show As" Designation.

9. Map OpenAir user and Exchange user mailbox information using the table on the main OpenAir
Exchange Setup window. See Mapping OpenAir Users and Exchange User Mailboxes.

10. Click File > Save to save the integration configuration and mapping information.

11. Click File > Exit to close OpenAir Exchange Setup.

12. (Optional) Review and change advanced settings in the Windows registry. See OpenAir Exchange
Manager Registry Settings.

OpenAir Exchange Setup Overview
The main OpenAir Exchange Setup window includes a top menu bar and a table matching each OpenAir
employee (user) record with a user mailbox.
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Click the menu headers to view the available menu options:

■ File — The File menu includes the following options:
□ Save — Click Save to save the integration configuration and mapping information.
□ Update — Click Update to fetch the latest information about OpenAir employee (user) records and

Exchange mailboxes and populate or update the OpenAir user – Exchange user mailbox mapping
information.

Note: Refresh the OpenAir user – Exchange user mailbox mapping information when
changing users' time zone preferences change in OpenAir.

□ Exit — Click Exit to close OpenAir Exchange Setup.
■ Options — The Options menu includes the following options:

□ OpenAir Settings — You must enter your OpenAir sign-in details to connect OpenAir Exchange
Manager with your OpenAir account. See Connecting OpenAir Exchange Manager with your
OpenAir account.

□ Integration Settings — You must provide information to connect OpenAir Exchange Manager
with Active Directory or Azure Active directory, and Exchange before you can map OpenAir users
with their corresponding Exchange mailboxes.
▬ Connecting OpenAir Exchange Manager with On-Premise Active Directory Using LDAP.
▬ Connecting OpenAir Exchange Manager with On-Premise Exchange Server.
▬ Connecting OpenAir Exchange Manager with Azure Active Directory or Exchange Online.
Use the Integration settings to control integration options and enable the bidirectional integration
if you want to import Exchange calendar events into OpenAir as bookings.
▬ Sending OpenAir Exchange Integration Logs to a Designated Email Address.
▬ Configuring the Synchronization of OpenAir Bookings and Exchange Calendar Events.

□ Manually edit Exchange users — You can enter the list of Exchange user mailboxes manually,
including information about the Exchange organization each mailbox is stored in, or you can
import the list from a CSV file. See Editing Exchange User Mailbox Information.

■ Help — The Help menu includes the following options:
□ User Guide (pdf) — Click to view the Exchange Integration Manager documentation for the

version installed in PDF format.
□ Contents (Release notes) — Click to view the readme.txt file for the version installed.
□ OpenAir Web Site — Click to view the OpenAir website (www.openair.com) in your default browser.
□ Display Log — You can view the log files in your default text editor. The following log files are

available as submenu items:
▬ Click Configuration to view the log file listing all setup and configuration actions performed

using OpenAir Exchange Setup (OpenAirExchange.log).
▬ Click Engine to view the log file listing all OpenAir Exchange Engine actions with dates and

times. (OpenAirExchangeEngine.log).

Note: You should attach a copy of both log files when contacting OpenAir Customer
Support to report an issue with OpenAir Exchange Manager. See Troubleshooting Exchange
Integration Manager.

□ About OpenAir Exchange — Click About OpenAir Exchange to view version information.

After you enter all configuration settings and fetch account and mailbox information from OpenAir and
Exchange, you can map OpenAir users with their corresponding Exchange mailboxes using the table on
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the main OpenAir Exchange Setup window. The mapping information also determines which OpenAir
transactions (task assignments, bookings, time-off requests) are exported to Exchange and whether
Exchange calendar events are imported into OpenAir for each mapped user.

Connecting OpenAir Exchange Manager with your
OpenAir account
You must connect OpenAir Exchange Manager with your OpenAir account before you can use it to
exchange information between OpenAir and Exchange.

You must provide the sign-in details of an OpenAir account administrator to set up and run the OpenAir
<> Exchange integration.

To connect OpenAir Exchange Manager with your OpenAir account

1. In OpenAir Exchange Setup, go to Options > OpenAir Settings

The OpenAir Settings window appears.

2. Enter your Company ID, User ID, and Password. You must be an account administrator to.

3. (Optional) Check the Remember Password box to store your OpenAir credentials on this
computer. When checked, the password is encrypted using industry standard security measures
and stored on your computer. You will not need to enter your password again to run the OpenAir
<> Exchange integration unless you change your password in OpenAir.

4. Server — Enter the URL for your OpenAir Account. The server URL includes the domain name for
your OpenAir account <account-domain>. For more information about your account-specific domain
name, see the help topic Your Account URLs.

5. Click OK.

Note: By clicking on the OK button, you understand and agree that the use of Oracle's
application is subject to the Oracle.com Terms of Use. Additional details regarding Oracle’s
collection and use of your personal information, including information about access,
retention, rectification, deletion, security, cross-border transfers and other topics, is
available in the Oracle Privacy Policy.
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Registering OpenAir Exchange Manager With
Microsoft Identity Platform

Note: The steps described in this topic are provided for illustration purposes only. Refer to the
vendor documentation for detailed instructions about integrating an application with Microsoft
identity platform. See Quickstart: Register an application with the Microsoft identity platform and
Quickstart: Configure a client application to access a web API on the Microsoft website for more
information.

Before you can connect OpenAir Exchange Manager with Azure Active Directory, Exchange Online,
or both, you must register OpenAir Exchange Manager with the Microsoft identity platform first. The
Microsoft identity platform provides secure sign-in and authorization for OpenAir Exchange Manager to
access Azure Active Directory or Exchange Online through the relevant Web APIs using OAuth 2.0.

To register OpenAir Exchange Manager with Microsoft identity platform

1. Sign in to the Azure portal.
2. If your account gives you access to more than one tenant, select the account you require in the top

right corner.
3. Go to Azure Active Directory.
4. Click App registrations under Manage on the left pane.

The App registrations screen appears.
5. Click New registration. The Register an application screen appears.
6. Enter a Name for the application — for example “OpenAir Exchange Manager” — and select

Accounts in this organizational directory only (<Your tenant name> only — Single tenant) under
Supported account types.

7. Click Register.
The Overview screen for your new app appears.
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8. Copy the Application (client) ID and Directory (tenant) ID and store this information in a
safe place. You will need this information when configuring OpenAir Exchange Manager. See
Connecting OpenAir Exchange Manager with Azure Active Directory or Exchange Online.

9. Click API permissions under Manage on the left pane.

The API permissions screen appears.

10. Click Add a permission.

The Request API permissions screen appears.

11. Click Exchange under Supported legacy APIs, then click Application permissions, and check the
full_access_as_app box under Select permissions.

12. Click Add permissions.

The API permissions screen appears and the application permission full_access_as_app for the
Exchange API is included in the list of Configured permissions.

13. Click Add a permission, click Microsoft Graph under Commonly used APIs, click Application
permissions, scroll to, and expand User permissions, check the User.Read.All box, and click Add
permissions.

The API permissions screen appears and the application permission User.Read.All for the Microsoft
Graph API is included in the list of Configured permissions.

14. Click Grant admin consent for <Your tenant name> and Accept on the consent prompt.

The API permissions screen shows the admin consent status for configured permissions as
granted for <Your tenant name>.

Note: You must have administrator privileges to grant admin consent to the permissions
configured for the application.
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15. Click Certificates & secrets under Manage on the left pane.

The Certificates & secrets screen appears.

16. Click New client secret.

The Add a client secret window appears.

17. Enter a Description and select when the client secret Expires, then click Add.

The Certificates & secrets screen shows the client secret you have added.

18. Copy the Client secret Value and store it in a safe place. You will need this information when
configuring OpenAir Exchange Manager. See Connecting OpenAir Exchange Manager with Azure
Active Directory or Exchange Online.

Connecting OpenAir Exchange Manager with Azure
Active Directory or Exchange Online
You can connect OpenAir Exchange Manager with:

■ Azure Active Directory to retrieve user information.

■ Exchange Online to export project task assignments, resource bookings, and schedule request
calendar commitments from OpenAir to user mailboxes as calendar events, or import Exchange
calendar events into OpenAir as bookings.

Before you can connect OpenAir Exchange Manager with Azure Active Directory or Exchange Online, you
must register OpenAir Exchange Manager with Microsoft identity platform. Registration provides secure
sign-in and authorization for Open Air Exchange Manager to access Azure Active Directory or Exchange
Online using OAuth 2.0. See Registering OpenAir Exchange Manager With Microsoft Identity Platform.

To configure the integration with Azure Active Directory or Exchange Online:

1. In OpenAir Exchange Setup, go to Options > Integration Settings
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The Integration Settings window appears.

2. If you are using Azure Active Directory, do the following steps:

a. Click the Active Directory tab.

b. Click the Choose the type of your AD dropdown, and select Azure AD.

Note: Skip these steps if you use an on-premises instance of Active Directory or if you do
not use Active Directory.

3. Click the Azure App tab.

4. Enter the Azure Application Credentials for the app you registered using the Azure portal :

■ Tenant — Enter the value for Directory (tenant) ID displayed on the Overview screen of your
app registration on the Azure portal.

■ Client ID — Enter the value for Application (client) ID displayed on the Overview screen of
your app registration on the Azure portal.

■ Secret — Enter the value for the Client secret you added on the Certificates & secrets screen
of your app registration on the Azure portal.

For more information about registering OpenAir Exchange Manager on the Azure portal and
obtaining the application credentials, see Registering OpenAir Exchange Manager With Microsoft
Identity Platform

5. Enter the Azure Exchange Server Name. This is the domain name for Exchange Online — in most
cases, you can keep the default value outlook.office365.com.

Important: This domain name is used by OpenAir Exchange Manager to detect whether
a mailbox is hosted on-premises or in Exchange Online. If you are using Exchange Online
to host mailboxes, Azure Exchange Server Name must match exactly the Exchange server
value that OpenAir Exchange Manager receives from the Exchange Autodiscover service, or
the Exchange server value you specify for individual users in OpenAir Exchange Setup (see
Editing Exchange User Mailbox Information).

6. Click OK.
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Connecting OpenAir Exchange Manager with On-
Premise Active Directory Using LDAP
You can connect OpenAir Exchange Manager with on-premise Active Directory to source user
information. In this case OpenAir Exchange Manager uses the LDAP protocol to access the user catalog in
Active Directory.

To connect OpenAir Exchange Manager with on-premise Active Directory using
LDAP:

1. In OpenAir Exchange Setup, go to Options > Integration Settings

The Integration Settings window appears.

2. Click the Active Directory tab.

3. Click the Choose the type of your AD dropdown, and select LDAP.

4. (Optional) Enter an LDAP query in the LDAP search filter box . You can use the LDAP search filter
for complex LDAP searches. Under normal circumstances, you should be able to keep the default
value. You can use the LDAP search filter to query a single Active Directory domain or a global
catalog.

5. In the Active Director container box, select one of the following options:

■ Use global catalog — Select this option if exchange users exist on more than one Exchange
Server in the forest.

■ Use domain — Select this option to retrieve exchange users from the Active Directory domain.
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Note: If your organization is large and only a small group are OpenAir users,you should
create a dedicated OpenAirUsers domain user group. The name of this group should be
included in the LDAP search filter. The narrowed-down search restricts the global list of
users to OpenAir users only. This simplifies the configuration and maintenance of the
integration.

6. Enter a Global catalog or Domain — the domain name for the forest root or the Active Directory
domain —, and an administrator User name and Password.

Tip: You can click Autodetect domain to use the domain you are connected to.

7. Click OK.

Connecting OpenAir Exchange Manager with On-
Premise Exchange Server
You can connect OpenAir Exchange Manager with an on-premise Exchange Server organization to export
task assignments, bookings, and time-off requests from OpenAir to user mailboxes as calendar events.

To connect OpenAir Exchange Manager with on-premise Exchange Server:

1. In OpenAir Exchange Setup, go to Options > Integration Settings
The Integration Settings window appears.

2. Click the Exchange on-premises tab.
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3. Select the Authentication Type according to the Exchange Server Authentication configuration
on Outlook Web Access (OWA). In most cases, you should be using Windows Integration
Authentication.

4. (Optional) Enter a Domain.
5. Enter a User name (this can be a UPN name), and Password. The domain account must have read

and write access permissions to the mailboxes of all users configured in the integration.
6. Click the Exchange Version dropdown and select one of the supported versions.

Important: The OpenAir Exchange integration support access to user mailboxes across
multiple instances of Exchange server running the same version. It does not allow access to
user mailboxes across multiple instances of Exchange server with different versions.

7. Check the Use http box if the integration is local to the Exchange Server and the Exchange Server
is not setup to accept https traffic.

8. Check the Override SSL Exceptions box if the SSL certificate is not signed, or if the domain name
used by the integration does not match the domain in the SSL certificate.

9. Check the Use full email address as mailbox name box if applicable.
10. Check the Use EWS Autodiscovery box to Autodiscover the correct EWS endpoint for Exchange

user mailboxes.

Note: Consider the following guidelines:

■ Checking the Use EWS Autodiscovery box disables the Use http check box. This information
is obtained directly by the Autodiscover service.

■ By default, OpenAir Exchange Manager retrieves all Microsoft Exchange user accounts when
using the Autodiscover service. This can take a very long time depending on the number of
users. To save time, you can perform an incremental update and retrieve only the missing
Microsoft Exchange user accounts. See Mapping OpenAir Users and Exchange User Mailboxes.

■ If the Autodiscover service fails for any user, the details are logged and the process continues
with the remaining users.

■ If the EWS URL is changed on the Exchange server side the Update function must be executed
again to set the value in the Exchange Manager database. See Mapping OpenAir Users and
Exchange User Mailboxes.

■ The Autodiscover service uses an email address to locate the configuration information that is
needed to create a connection to an Exchange server. Only a credentialed user of the domain
can use the Autodiscover service.

Sending OpenAir Exchange Integration Logs to a
Designated Email Address
You can configure OpenAir Exchange Manager to send integration logs to a designated email address.
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To send the OpenAir Exchange integration logs to a designated email address:

1. In OpenAir Exchange Setup, go to Options > Integration Settings

The Integration Settings window appears.

2. Click the Logging tab.

3. Check the Send results of each run box if you want a log of each synchronization to be sent to the
specified email address . A message is sent and if errors occur, the number of errors appears in the
title of the message to alert the receiver.

4. Enter the email address in To Email Address.

5. Enter the SMTP Server Name.

6. Check the Use Authentication box and enter the User name and Password if you must
authenticate to use the SMTP service to send email.

7. Click OK.

Configuring the Synchronization of OpenAir
Bookings and Exchange Calendar Events
By default, OpenAir Exchange Manager only exports task assignments, bookings, and time off requests
from OpenAir to user mailboxes as calendar events, and updates the calendar events in user mailboxes
when changes are made to the task assignment, booking, or time off request in OpenAir.

You can configure OpenAir Exchange Manager to import calendar events created in the email client into
OpenAir as bookings, and update these bookings when changes are made to the calendar events in the
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email client. OpenAir Exchange Manager refers to this added functionality as the bidirectional integration
or the synchronization of OpenAir bookings and Exchange calendar events.

Important: Review the following guidelines:

■ The synchronization of OpenAir bookings and Exchange calendar events does not support
recurring calendar events.

■ All-day events are imported into OpenAir as bookings with 100% allocation.

■ Events with a start tome and end time create bookings with a specific number of hours.

To configure the synchronization of OpenAir bookings and Exchange calendar
events

1. In OpenAir Exchange Setup, go to Options > Integration Settings

The Integration Settings window appears.

2. Click the Sync tab.

3. Check the Export Booking Notes as-is box if you want the body of the calendar event in the
Exchange user mailbox to include only the content of the Notes field on the booking record and
no other booking information. Otherwise, the body of the calendar event includes formatted
information including the notes content and additional information.
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Note: The box is checked and read-only if you check the Enable bi-directional
integration.

4. Check the Enable bi-directional integration box if you want to import calendar events created in
the email client into OpenAir as bookings, and update these bookings when changes are made to
the calendar events in the Exchange user mailbox.

Additional settings become available on the Sync tab.

Note: Additional set up is required to enable the synchronization of OpenAir bookings
and Exchange calendar events for each mapped user. For more information, see Mapping
OpenAir Users and Exchange User Mailboxes.

5. Select a date from the Sync events created or modified after dropdown list. When running the
OpenAir <> Exchange Integration, only the calendar events created or modified after this date are
imported into OpenAir as bookings. This date is updated accordingly after each successful run of
OpenAir Exchange Engine.

6. Select an option from the Conflict Resolution dropdown list. This determines which information
should be used when the same information was changed both in the user mailbox calendar
event and on the OpenAir booking record. Select OpenAir wins to prioritize the OpenAir booking
information over the Exchange calendar event information, or Microsoft Exchange Server wins to
prioritize the Exchange calendar event information over the OpenAir booking information.

Note: The OpenAir <> Exchange integration performs a field-level merge in both
directions when different information (fields) were changed in the OpenAir booking and in
the corresponding user mailbox calendar event. For example, if the body content (Notes)
of the calendar event were modified in the email client and the booking start date was
changed in OpenAir, the integration updates both the Notes on the OpenAir booking and
the start date of the calendar event in the user mailbox. However, if the same information
was modified on both sides, the integration resolves the conflict based on your conflict
resolution preference.

7. Select the default Booking Type and the Project for booking records created when importing
calendar events from Exchange user mailboxes.

Note: You can override the default Booking Type and Project for each user. See Setting
the Default Booking Type and Project for Imported Bookings at the User Level.

Tip: Resize the Integration Settings window to show long text strings such as project
names in the Default Booking Properties dropdown. The Integration Settings window can
be resized if you are using OpenAir Exchange Manager 5.0 or later.

8. Check the Export private Outlook events box if you want calendar events marked as private to be
imported into OpenAir.

Note: A private calendar event typically does not impact a project or billing. It indicates
that the time is allocated and not available for assignment.

This setting applies to all mapped users for whom the synchronization of OpenAir bookings
and Exchange calendar events is enabled. It cannot be changed for individual users.

9. Select the action to be taken in OpenAir when a calendar event was deleted in the user mailbox
from the Deletion in Outlook dropdown lists. The following options are available:

■ is ignored by integration — If a calendar event was deleted in the user mailbox, no action is
taken. The integration does not delete OpenAir bookings.
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■ deletes booking created from Outlook event — If a booking was initially created from a
calendar event and the calendar event is subsequently deleted, the integration deletes the
matching booking in OpenAir. However, the integration does not delete bookings that were
initially created in OpenAir.

■ deletes booking regardless of origin — If a calendar event was deleted in the user mailbox
and a corresponding booking exists in OpenAir, the booking is deleted even if the booking was
initially created in OpenAir.

■ changes booking type to — If a calendar event is deleted in the user mailbox, the integration
sets the booking type to the selected value on the corresponding booking record in OpenAir.
For example, you can use a booking type named “Deleted” to indicate that the calendar event
corresponding to an OpenAir booking was deleted in the user mailbox.

Important: Review the following guidelines:

■ When a booking is deleted in OpenAir, the integration does not delete the calendar
event in the Exchange user mailbox. The calendar event must be deleted in the email
client's calendar.

Users should always delete calendar events in the email client's calendar and not the
corresponding booking in OpenAir. This allows the OpenAir <> Exchange integration to
perform the appropriate action as per the integration configuration.

■ If the event was hard-deleted in the email client, the integration is not able to detect
that deletion. Configure the retention policy so that deleted items are not removed from
the store.

10. Click OK.

11. Enable the synchronization of OpenAir bookings and Exchange calendar events for individual
users. You can do this using the mapping table in the main OpenAir Exchange Setup window. See
Mapping OpenAir Users and Exchange User Mailboxes.

Important: The synchronization of OpenAir bookings and Exchange calendar events
requires access rights to user mailboxes

■ If you use Exchange Server 2010 or later version, configure Exchange impersonation
for the user before enabling the synchronization of OpenAir bookings and Exchange
calendar events for this user. For more information about configuring Exchange
impersonation, see the vendor documentation.

■ If you use Exchange 2007, grant Full Access permission for the user mailbox before
enabling the synchronization of OpenAir bookings and Exchange calendar events for
this user. For more information, see the vendor documentation.

Setting the Default Booking Type and Project for Imported
Bookings at the User Level
When you configure the synchronization of OpenAir bookings and Exchange calendar events, you select
the default Booking Type and Project for booking records created when importing calendar events from
Exchange user mailboxes.
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To be able to select the default booking type and project for imported bookings at the user level, create
the following custom fields for the Employee record type in OpenAir. If you do not select a value at the
user level in OpenAir, the default set in OpenAir Exchange Setup is used.

For more information about creating the custom fields, see the help topics Custom Fields and Custom
Field Types.

Name Type List source Description

exchDefault_booking_type Pick List Booking Type Select the default Booking type for booking records
created when importing calendar events from the
Exchange user mailbox.

exchDefault_project Pick List Project Select the default Project for booking records created
when importing calendar events from the Exchange
user mailbox.

Mapping OpenAir Users and Exchange User
Mailboxes
After you have entered the necessary information to connect OpenAir Exchange Manager with your
OpenAir account, Active Directory or Azure Active Directory, and Exchange Server or Online, you can map
OpenAir employee (user) records with the corresponding Exchange user mailboxes.

To map OpenAir users and Microsoft Exchange users manually:

1. In OpenAir Exchange Setup, click File > Update.

If user mailboxes are stored in on-premise Exchange Server organizations and you checked the
Use EWS Autodiscovery box on the Integration Settings form, a dialog appears.

■ To retrieve only the missing Exchange user mailboxes, click Yes.

■ To retrieve all Exchange user mailboxes, click No.

Note: By default, OpenAir Exchange Manager fetches all Exchange user mailboxes when
using the Autodiscover service to retrieve the correct EWS endpoint for each user. This
can take a long time depending on the number of users. To save time, you can perform
an incremental update and fetch only the missing Exchange user mailboxes. For more
information about EWS endpoint autodiscovery, see Connecting OpenAir Exchange
Manager with On-Premise Exchange Server.

You can add and remove Exchange user mailboxes manually or import them from a CSV file
at any time. See Editing Exchange User Mailbox Information.

The OpenAir Exchange Setup window lists OpenAir users and Exchange user mailboxes in
the mapping table. OpenAir Exchange Setup maps OpenAir employee (user) records and
Exchange user mailboxes with a matching email address automatically. The mapping table shows
[Select ...] under the Microsoft Exchange column when there are no user mailboxes matching
the email address on the OpenAir employee (user) record.

2. Map OpenAir employee (user) records and Exchange user mailboxes that do not have a matching
email address manually. Repeat the following steps for each row showing [Select ...] under the
Microsoft Exchange column:
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a. Click [Select ...].

b. Select the user mailbox for the OpenAir user. The mapping table shows the name and email
address recorded on the OpenAir employee (user) record under the OpenAir column.

3. For each OpenAir user – Exchange user mailbox pair, select which types of OpenAir transactions
you want to export. If you have enabled the synchronization of OpenAir bookings and Exchange
calendar events (bidirectional integration), choose whether to synchronize OpenAir bookings and
Exchange calendar events for each user. Each export or synchronization feature is represented by
a different color dot in the mapping table

■ A blue color dot  indicates that OpenAir bookings for this user are exported to the Exchange
user mailbox as calendar events.

■ A green color dot  indicates that OpenAir time off requests (schedule requests) for this user
are exported to the Exchange user mailbox as calendar events.

■ A purple color dot  indicates that OpenAir task assignments for this user are exported to the
Exchange user mailbox as calendar events.

■ A red color dot  indicates that calendar events in the Exchange user mailbox are imported
into OpenAir as bookings for this user if the synchronization of OpenAir bookings and Exchange
calendar events (bidirectional integration) is enabled.

Click under the color dot columns turn each integration option on or off for each user.

Tip: Select multiple rows and click the column header to change the integration option for
all selected users at the same time.

For more information about the bidirectional integration, see Configuring the Synchronization of
OpenAir Bookings and Exchange Calendar Events.

4. Click File > Save.
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Editing Exchange User Mailbox Information
You can enter and modify the list of Exchange user mailboxes manually, including information about the
Exchange organization each mailbox is stored in, or you can import the list from a CSV file.

To edit Exchange user mailbox information:

1. In OpenAir Exchange Setup, go to Options > Manually edit Exchange users.
The Exchange users window appears. The table lists the Exchange user mailboxes available for
mapping in OpenAir Exchange Setup and the Exchange organization each user mailbox is stored
in.

2. To add new user mailboxes, do the following for each user mailbox you want to add:
a. Scroll down to the bottom of the table.
b. On an empty row, enter the email address associated with the user mailbox under

Exchange user and the Exchange organization under Exchange server.
c. Press Enter or click a cell in the next empty row.

3. To remove user mailboxes, do the following for each user mailbox you want to remove:
1. Select the user mailbox.
2. Press Delete.

Tip: Press Shift and Ctrl keys to select multiple users.

4. To change the Exchange organization a user mailbox is stored in:
a. Select the user mailbox.
b. Click Set Exchange server....

A dialog appears.
c. Enter the new Exchange organization name.
d. Click OK.

Tip: Select multiple rows and click Set Exchange server to change the Exchange
organization for several user mailboxes at the same time.

5. To import users from a CSV file:
a. Click Import from file.
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The Import from file window appears.

b. Click the Browse button (...).
A file selection dialog appears.

c. Select the CSV file containing the information to import. The CSV file must contain 2 columns
separated by commas (,), and include plain data only without column headers. The following
example shows the correct CSV format:

jadmin@example.com,corp-exch-win2012-1
admin@example.com,corp-exch-win2012-1
mcollins@example.com,corp-exch-win2012-2

d. Do one of the following:
■ Check the Add new users box to import Exchange user mailboxes from the CSV file only

if the email addresses corresponding to these user mailboxes are not already listed in
OpenAir Exchange Setup.

■ Check the Replace existing users box to replace already listed Exchange user mailboxes
with information from the CSV file.

■ Check both boxes to add new user mailboxes and replace existing user mailboxes.
e. Click Run import.

6. Click OK to validate the changes and return to the main OpenAir Exchange setup window.
7. Click File > Save.

Mapping OpenAir Booking Type to Exchange
Calendar Event "Show As" Designation
By default, when you export bookings from OpenAir to Exchange user mailboxes, the resulting calendar
event will show as Free time. You can map booking types in OpenAir to specific "Show As" designation
for the calendar event in Exchange user mailboxes so that the resulting calendar event shows as Free,
Tentative, Busy, or Out of Office, depending on the booking type. You can also exclude bookings from the
export, depending on the booking type.

To be able to map the booking type to Exchange calendar event "Show as" designation, create the
following custom field for the Booking Type record type in OpenAir. If you do not select a value for a
booking type in OpenAir, the calendar event shows as Free time.

After you create the custom field, go to Administration > Application Settings > Resources > Booking
Types and edit each booking type record, selecting a "Show as" designation for the exported calendar
events or Do not export.
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For more information about creating the custom fields, see the help topics Custom Fields and Custom
Field Types.

Name Type Values Description

calendar_export_type Dropdown ■ Set event time as
free

■ Set event time as
tentative

■ Set event time as
busy

■ Set event time as
out of office

■ Do not export

Select the Show as designation for calendar
events created or modified when exporting
bookings from OpenAir to Exchange user
mailboxes.

Note: Review the following guidelines:

■ Calendar events show as Busy only if the booking has a Start time and End time defined in
OpenAir.

■ The dropdown option values must be exactly as listed above.

■ Check the Required box only if you require that each booking type to be mapped to a "Show
as" designation or excluded from the export.

OpenAir Exchange Manager Registry Settings
Additional configuration settings are available in the Windows Registry.

The following registry keys are available to set the time delay (in seconds) between one synchronization
loop and the next.

■ LoopWaitTimeCriticalError (default: 600 seconds) — Loop delay (in seconds) when the last
synchronization run returned a critical error (A critical error may be returned if, for example, either
Microsoft Exchange Server or OpenAir are not available ).

■ LoopWaitTimeNoRecordsToSync (default: 300 seconds) — Loop delay (in seconds) when no new
records were found for mapped user during the last synchronization run.

■ LoopWaitTimeRecordsPendingSync (default: 5 seconds) — Loop delay (in seconds) when there
are still records waiting to be synchronized between OpenAir and Microsoft Exchange after the last
synchronization run.

The following registry key is available to set the maximum size for the OpenAir Exchange Engine log file.

■ MaxSizeOfLogFile (default: 209715200 bytes) — Maximum Size (in bytes) of the Exchange Engine log
file.
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Note: If the log file exceeds the maximum size specified, a new log file is created.

The following registry key is available to set the number of simultaneous processes used to autodiscover
the correct Exchange Web Services endpoint for Exchange users configured for integration.

■ AutodiscoverProcessCount (default: 3) — Number of simultaneous processes used to autodiscover
the Exchange Web Services endpoints. Increasing this setting can speed up the operation but also can
lead to an increased load on the Exchange server, and timeout failure for some users. Use this registry
setting with caution.

To edit OpenAir Exchange Manager Registry Settings

1. Open the Windows Run command (shortcut: Ctrl + R).

2. Enter regedit and click Open. The Registry Editor opens.

3. Go to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\OpenAir
\ExchangeManager.

4. For each key you want to edit:

a. Double-click the name of the key. A window appear letting you edit the value.

b. Enter the value data.

c. Click OK.

5. Go to File > Exit to exit the Registry Editor.

Important: Care should be taken when editing the Registry. You should not change any other
settings than those listed above.
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Running the OpenAir Exchange Integration
After you set up the OpenAir <> Exchange integration, you can run OpenAir Exchange Engine to export
task assignments, bookings, and time off requests (schedule requests) from OpenAir to Exchange user
mailboxes as calendar events and import calendar events from Exchange user mailboxes to OpenAir as
bookings if the bidirectional integration is enabled.

If you use OpenAir Exchange Manager 5.0 or later version, you can run OpenAir Exchange Engine as a
Windows service. See Running OpenAir Exchange Engine as a Windows Service.

Important: You should not use Task Scheduler to run OpenAir Exchange Manager 4.0 or later
version.

OpenAir Exchange Engine uses the following process:

1. OpenAir Exchange Engine checks for new information in OpenAir and fetches all new information
from OpenAir if found.

2. OpenAir Exchange Engine sends the new information from OpenAir to Exchange.
3. OpenAir Exchange Engine waits for a response from Exchange and updates OpenAir with the

information received.

You can view console logs to check the status of your OpenAir <> Exchange integration at any time. See
Viewing Console Logs for the OpenAir Exchange Integration.

Running OpenAir Exchange Engine
To run OpenAir Exchange Engine you must have:

■ Administrator role in Windows or Windows Server.
■ Read and write access to all Exchange user mailboxes the integration is configured to export to and

import from

To run OpenAir Exchange Engine:

1. Launch OpenAir Exchange Setup. To do so, do one of the following:
■ Go to the application installation directory (the default installation directory is C:\Program Files

(x86)\OpenAir\ExchangeManager). Click OpenAirExchangeEngine.exe.
■ Go to the Windows start menu, scroll down to OpenAir Exchange Manager, expand the

program folder and click Start Engine.
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A command line window opens and runs the OpenAir Exchange Engine as it has been configured.
See Setting Up the OpenAir Exchange Integration.

2. OpenAir Exchange Engine runs continuously in the background after you launch it. To stop
OpenAir Exchange Engine, go to the Windows start menu, scroll down to OpenAir Exchange
Manager, expand the program folder and click Stop Engine.

Running OpenAir Exchange Engine as a Windows
Service
If you use OpenAir Exchange Manager 5.0 or later version, you can run OpenAir Exchange Engine as a
Windows service.

To run OpenAir Exchange Engine as a Windows service

1. Launch the OpenAir Exchange Tray Monitor. To do so, do one of the following:

■ Go to the application installation directory (the default installation directory is C:\Program Files
(x86)\OpenAir\ExchangeManager). Click OpenAirExchangeTrayMonitor.exe.

■ Go to the Windows start menu, scroll down to OpenAir Exchange Manager, expand the
program folder and click Tray Monitor.

2. Go to the taskbar system tray, locate and the right-click the OpenAir Exchange Tray Monitor icon
and click Install Service.

3. After the service installation completes, right-click the OpenAir Exchange Tray Monitor icon and
click Start Service or Stop Service to control the service, or click Stats to open the OpenAir
Exchange Monitor window and review the status and activity of the OpenAir Exchange Windows
service.
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When OpenAir Exchange Manager 5.0 or later is installed, the following shortcuts are available from the
Windows start menu:

■ OpenAir Exchange Manager — Opens the Exchange Manager interface

■ Start Engine — Runs the OpenAir Exchange Engine in the background

■ Stop Engine — Stops the OpenAir Exchange Engine

■ Show console logs for Engine – Opens a log file which describes Exchange Engine’s current progress if
running, or a notification that it is not currently running.

■ Tray Monitor — Starts the taskbar System Tray utility to control and monitor the OpenAir Exchange
Engine Windows service.

Viewing Console Logs for the OpenAir Exchange
Integration
You can view console logs to check the status of your OpenAir <> Exchange integration at any time and
audit changes to the integration configuration.

Two logs are available for the

■ The Configuration log lists all setup and configuration actions performed using OpenAir Exchange
Setup (OpenAirExchange.log).

■ The Engine log lists all OpenAir Exchange Engine actions with dates and times.
(OpenAirExchangeEngine.log).

You should attach a copy of both log files when contacting OpenAir Customer Support to report an issue
with OpenAir Exchange Manager. See Troubleshooting Exchange Integration Manager.

To view console logs for the OpenAir <> Exchange integration:
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1. Do one of the following:

■ Go to the application installation directory (the default installation directory is C:\Program Files
(x86)\OpenAir\ExchangeManager) and double-click the log file to open it in your default text
editor.

■ Go to the Windows start menu, scroll down to OpenAir Exchange Manager, expand the
program folder and click Show console logs for Engine to view the Engine log.

■ In OpenAir Exchange Setup, go to Help > Display Log > [Choose the log].

■ Right-click the OpenAir Exchange Tray Monitor icon and click Log to view the Engine log.
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Troubleshooting Exchange Integration
Manager
The first step in troubleshooting is to ensure that you have installed the latest version of the OpenAir
Exchange Manager so that you have the most recent enhancements, fixes, and features. Refer
to Installing, Updating and Uninstalling OpenAir Exchange Manager for more information and
considerations for updating.

If you are experiencing difficulties with OpenAir Exchange Manager or would like to enable an optional
feature for your OpenAir account, create a support case. Our Customer Support staff and engineers will
work with you to find a solution to your problem. See Creating a Support Case.

Before you create a support case, review the list of common errors and their solutions.

Important: Make sure you attach the OpenAir Exchange Manager log file (compressed as a ZIP
file) when creating a support case. For more information about accessing the log files, see Viewing
Console Logs for the OpenAir Exchange Integration.

Troubleshooting Common Problems
The following table lists common errors or scenarios and their solutions. Use this table in addition to
the Integration Manager log file to try and troubleshoot your integration before you contact OpenAir
Customer Support.

Error / Scenario Solution

Error "The remote server returned an error:
(403) Forbidden"

Verify that the version of Exchange Server specified in OpenAir
Exchange Setup matches the version of Exchange Server you are
running on your mail server. See Connecting OpenAir Exchange
Manager with On-Premise Exchange Server.

Error: "Exchange Server doesn't support the
requested version"

Verify that the version of Exchange Server specified in OpenAir
Exchange Setup matches the version of Exchange Server you are
running on your mail server. See Connecting OpenAir Exchange
Manager with On-Premise Exchange Server.

Error: "Exception: The handle is invalid"
when exporting bookings from OpenAir to
user mailboxes stored in an Exchange Online
organization.

Verify your Exchange Online credentials. In particular, verify that
the client secret is still valid. This error is often due to an expired
client secret. See Connecting OpenAir Exchange Manager with
Azure Active Directory or Exchange Online and Registering OpenAir
Exchange Manager With Microsoft Identity Platform.

Error: "Could not lock file" when running
OpenAir Exchange Setup .

Sign in to Windows as an administrator, and run OpenAir Exchange
Setup again, or right-click the shortcut and choose Run as
administrator.

Error: "Status: Access is not enabled.
Please contact your OpenAir account
administrator to enable this
functionality." when clicking File > Update in
OpenAir Exchange Setup

Contact OpenAir Customer Support and request the following for
your account:

■ Disable and enable again Access to OpenAir Exchange Manager.

■ Enable and disable again Access to OpenAir Outlook Connector.

The Exchange user mailbox dropdown list
does not include the user mailbox I want to
map to the OpenAir user record.

Verify that the user mailbox is not already mapped to another
OpenAir user record.
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Creating a Support Case
If you are experiencing difficulties with OpenAir or would like to enable an optional feature, go to
SuiteAnswers through the Support page in OpenAir and create a support case.

Our support staff and engineers will work with you to find a solution to your problem.

Important: Be sure to review the Support Usage Best Practice Guidelines, Case Severity
Definitions and Case Resolution Overview before you submit a support case or call the Support
team.

As a part of the support case creation process you will be presented with existing answers that
may solve your problem. Take a moment to view the available answers before proceeding to
create a support case.

To create a support case:

1. Sign in to your company’s OpenAir account and select Support from the user menu.
2. Click Go to SuiteAnswers.
3. On the SuiteAnswers website, click Contact Support Online.

4. Enter keywords corresponding to the question or problem you want to resolve and click Search.

Note: If you do not have a question but need a feature enabled, for example, click Search.

5. Oftentimes, the answer to your question will be displayed. If you still want to create a support case,
click Continue to Create Case.

6. Fill out the Create Case form and then click Submit. You will receive an email confirmation with
your support case reference (OpenAir Customer Care #).
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Important: Review the Case severity definitions and always use the appropriate case
severity when submitting a case. See the help topic Case Severity Definitions.

Using the appropriate case severity helps OpenAir Customer Support prioritize between
cases. Otherwise, OpenAir Customer Support need to evaluate the true urgency of each
case, which slows down the response time to all cases.

Note: An asterisk * indicates a required field.

Exchange Integration Manager

https://app.openair.com/help/index.html?topic=article_0416112923#subsect_45114749752

	Table of Contents
	Exchange Integration Manager Overview
	Getting Started with Exchange Integration Manager
	System Requirements and Technical Considerations
	Installing, Updating and Uninstalling OpenAir Exchange Manager
	Setting Up the OpenAir Exchange Integration
	OpenAir Exchange Setup Overview
	Connecting OpenAir Exchange Manager with your OpenAir account
	Registering OpenAir Exchange Manager With Microsoft Identity Platform
	Connecting OpenAir Exchange Manager with Azure Active Directory or Exchange Online
	Connecting OpenAir Exchange Manager with On-Premise Active Directory Using LDAP
	Connecting OpenAir Exchange Manager with On-Premise Exchange Server
	Sending OpenAir Exchange Integration Logs to a Designated Email Address
	Configuring the Synchronization of OpenAir Bookings and Exchange Calendar Events
	Setting the Default Booking Type and Project for Imported Bookings at the User Level

	Mapping OpenAir Users and Exchange User Mailboxes
	Editing Exchange User Mailbox Information

	Mapping OpenAir Booking Type to Exchange Calendar Event "Show As" Designation
	OpenAir Exchange Manager Registry Settings

	Running the OpenAir Exchange Integration
	Troubleshooting Exchange Integration Manager
	Troubleshooting Common Problems

	Creating a Support Case

